• Jan Djärv's avatar
    Check for OSX >= 10.4 to match what the maunal says and what we actually support. · 335f5ae4
    Jan Djärv authored
    * configure.ac: Check that OSX is 10.4 or newer.
    
    * etc/NEWS (NextStep/OSX port changes): OSX 10.4 or newer is required.
    
    * src/nsfns.m (Fns_list_services): Remove comment and check for OSX < 10.4.
    (ns_do_applescript): Remove check for >= MAC_OS_X_VERSION_10_4.
    
    * src/nsimage.m (setPixmapData, getPixelAtX, setAlphaAtX): Remove onTiger.
    
    * src/nsmenu.m (fillWithWidgetValue:): Remove code for < MAC_OS_X_VERSION_10_2.
    
    * src/nsselect.m (ns_string_from_pasteboard): Remove check for >=
    MAC_OS_X_VERSION_10_4.
    
    * src/nsterm.h (MAC_OS_X_VERSION_10_3, onTiger): Remove.
    (EmacsApp): Remove check for >= MAC_OS_X_VERSION_10_4.
    (struct nsfont_info): Remove check for >= MAC_OS_X_VERSION_10_3.
    335f5ae4
nsmenu.m 51.9 KB