• Eli Zaretskii's avatar
    Allow Emacs on w32 to build against and work with GnuTLS 3.x. · 651e947e
    Eli Zaretskii authored
     src/gnutls.c (init_gnutls_functions): Load gnutls_check_version.
     Load gnutls_transport_set_lowat only if GnuTLS version is below
     2.11.1.
     (emacs_gnutls_handshake): Call gnutls_transport_set_lowat only for
     GnuTLS versions below 2.11.1.
     lisp/term/w32-win.el (dynamic-library-alist) <gnutls>: Load
     libgnutls-28.dll, from GnuTLS version 3.x, in preference to
     libgnutls-26.dll.
    651e947e
ChangeLog 355 KB