• Paul Eggert's avatar
    Don't require pkg-config when building from repository. · c56327b5
    Paul Eggert authored
    * INSTALL: Prefer './configure FOO=BAR' to 'FOO=BAR ./configure'.
    * INSTALL.REPO: pkg-config is no longer required to build from
    the repository.
    * autogen.sh: Don't check for pkg-config.
    (progs): Remove pkg-config.
    (pkg_config_min, AUTORECONF_ENV, env_space, ACLOCAL_PATH):
    Remove.  All uses removed.
    * m4/pkg.m4: New file, built by admin/merge-pkg-config.
    * configure.ac: Remove unnecessary m4_pattern_forbid of ^PKG_ and
    an AC_ARG_VAR of PKG_CONFIG_PATH.  pkg.m4 does that for us.
    (EMACS_CHECK_MODULES): Remove workaround for old pkg-config bug,
    as we use pkg.m4 from a newer pkg-config.
    * admin/merge-pkg-config: New script.
    * admin/notes/copyright: Update for m4/*.m4, in particular m4/pkg.m4.
    * etc/NEWS: Prefer './configure FOO=BAR' to 'FOO=BAR ./configure'.
    * etc/PROBLEMS (Build-time-problems): Remove pkg-config problem
    that is no longer an issue.
    * nt/INSTALL: Remove no-longer-needed notes about pkg-config.
    c56327b5
copyright 24.3 KB