• Alexander Gramiak's avatar
    Bump minimum GTK versions to 2.24 and 3.10 · fc0f469f
    Alexander Gramiak authored
    * configure.ac: Bump required GTK 2 and GTK 3 versions and the
    associated GLib versions. Remove obsolete AC_CHECK_FUNCS calls. These
    check for functions available in later GTK 2 versions. These checks
    and can safely be removed with the exception of
    gtk_window_set_has_resize_grip, which according to a comment in
    gtkutil.c causes an issue in Ubuntu's GTK 2.
    
    * src/gtkutil.c:
    * src/xfns.c:
    * src/xterm.c:
    * src/xterm.h: Remove now unused conditional blocks. Use HAVE_GTK3
    instead of GTK_CHECK_VERSION where now applicable. Remove checks of
    now always true USE_GTK_TOOLTIP.
    fc0f469f
xterm.c 395 KB