Commit 01239f72 authored by Richard M. Stallman's avatar Richard M. Stallman
Browse files

Move #undef HAVE_STRERROR before the #includes.

parent 4a02b552
...@@ -140,6 +140,10 @@ and this notice must be preserved on all copies. */ ...@@ -140,6 +140,10 @@ and this notice must be preserved on all copies. */
#undef HAVE_AIX_SMT_EXP #undef HAVE_AIX_SMT_EXP
/* Define if you have the ANSI `strerror' function.
Otherwise you must have the variable `char *sys_errlist[]'. */
#undef HAVE_STRERROR
/* Define if `sys_siglist' is declared by <signal.h>. */ /* Define if `sys_siglist' is declared by <signal.h>. */
#undef SYS_SIGLIST_DECLARED #undef SYS_SIGLIST_DECLARED
...@@ -247,10 +251,6 @@ typedef unsigned long EMACS_UINT; ...@@ -247,10 +251,6 @@ typedef unsigned long EMACS_UINT;
#define BSTRING #define BSTRING
#endif #endif
/* Define if you have the ANSI `strerror' function.
Otherwise you must have the variable `char *sys_errlist[]'. */
#undef HAVE_STRERROR
/* Non-ANSI C compilers usually don't have volatile. */ /* Non-ANSI C compilers usually don't have volatile. */
#ifndef HAVE_VOLATILE #ifndef HAVE_VOLATILE
#ifndef __STDC__ #ifndef __STDC__
...@@ -258,19 +258,6 @@ typedef unsigned long EMACS_UINT; ...@@ -258,19 +258,6 @@ typedef unsigned long EMACS_UINT;
#endif #endif
#endif #endif
#if 0 /* This should be taken care of by autoconf now. */
/* joe@zircon.uucp says that in order to use XFree386, you have to
link against -lXbsd, which insists on defining the random
function.
faith@cs.unc.edu says this is bogus for Linux and several other OS's.
Eventually, we should have autoconf test for this. Anyone want to
submit a patch? */
#if defined (HAVE_XFREE386) && !defined (LINUX)
#define LIBX11_SYSTEM -lXbsd
#define HAVE_RANDOM
#endif
#endif
/* Some of the files of Emacs which are intended for use with other /* Some of the files of Emacs which are intended for use with other
programs assume that if you have a config.h file, you must declare programs assume that if you have a config.h file, you must declare
the type of getenv. the type of getenv.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment