Commit 08cf18e4 authored by Glenn Morris's avatar Glenn Morris
Browse files

(top-level): Remove unnecessary progn.

parent 3f527154
2009-09-18 Glenn Morris <rgm@gnu.org>
* allout.el (top-level): Remove unnecessary progn.
* progmodes/js.el (js-end-of-defun): Remove malformed and unneeded let.
* emacs-lisp/derived.el (define-derived-mode): Fix paren typo in
......
;;; allout.el --- extensive outline mode for use alone and with other modes
;; Copyright (C) 1992, 1993, 1994, 2001, 2002, 2003, 2004,
;; 2005, 2006, 2007, 2008, 2009 Free Software Foundation, Inc.
;; Copyright (C) 1992, 1993, 1994, 2001, 2002, 2003, 2004, 2005,
;; 2006, 2007, 2008, 2009 Free Software Foundation, Inc.
;; Author: Ken Manheimer <ken dot manheimer at gmail dot com>
;; Maintainer: Ken Manheimer <ken dot manheimer at gmail dot com>
......@@ -87,15 +87,14 @@
;; Most of the requires here are for stuff covered by autoloads.
;; Since just byte-compiling doesn't trigger autoloads, so that
;; "function not found" warnings would occur without these requires.
(progn
(require 'pgg)
(require 'pgg-gpg)
(require 'overlay)
;; `cl' is required for `assert'. `assert' is not covered by a standard
;; autoload, but it is a macro, so that eval-when-compile is sufficient
;; to byte-compile it in, or to do the require when the buffer evalled.
(require 'cl)
))
(require 'pgg)
(require 'pgg-gpg)
(require 'overlay)
;; `cl' is required for `assert'. `assert' is not covered by a standard
;; autoload, but it is a macro, so that eval-when-compile is sufficient
;; to byte-compile it in, or to do the require when the buffer evalled.
(require 'cl)
)
;;;_* USER CUSTOMIZATION VARIABLES:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment