Commit 0d71dfb3 authored by Tom Willemse's avatar Tom Willemse Committed by Stefan Monnier

* lisp/emacs-lisp/package.el (package--prepare-dependencies):

Accept requirements without explicit version.

Fixes: debbugs:14941
parent acc112c7
2014-03-13 Tom Willemse <tom@ryuslash.org> (tiny change)
* emacs-lisp/package.el (package--prepare-dependencies):
Accept requirements without explicit version (bug#14941).
2014-03-12 Juanma Barranquero <lekktu@gmail.com> 2014-03-12 Juanma Barranquero <lekktu@gmail.com>
* register.el (register-separator, copy-to-register): Doc fixes. * register.el (register-separator, copy-to-register): Doc fixes.
......
...@@ -1128,6 +1128,8 @@ is wrapped around any parts requiring it." ...@@ -1128,6 +1128,8 @@ is wrapped around any parts requiring it."
((symbolp dep) `(,dep "0")) ((symbolp dep) `(,dep "0"))
((stringp dep) ((stringp dep)
(error "Invalid requirement specifier: %S" dep)) (error "Invalid requirement specifier: %S" dep))
((and (listp dep) (null (cdr dep)))
(list (car dep) "0"))
(t dep))) (t dep)))
deps)))) deps))))
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment