Commit 12359245 authored by Glenn Morris's avatar Glenn Morris
Browse files

Minor cl.texi change.

* doc/misc/cl.texi (Organization, Installation, Old CL Compatibility):
Deprecate cl-compat for new code.
parent cee3168b
2010-10-08 Glenn Morris <rgm@gnu.org>
* cl.texi (Organization, Installation, Old CL Compatibility):
Deprecate cl-compat for new code.
2010-10-07 Glenn Morris <rgm@gnu.org>
* eudc.texi (CCSO PH/QI, LDAP Requirements): Remove old information.
......
......@@ -206,11 +206,12 @@ will take care of pulling in the other files when they are
needed.
There is another file, @file{cl-compat.el}, which defines some
routines from the older @file{cl.el} package that are no longer
routines from the older @file{cl.el} package that are not otherwise
present in the new package. This includes internal routines
like @code{setelt} and @code{zip-lists}, deprecated features
like @code{defkeyword}, and an emulation of the old-style
multiple-values feature. @xref{Old CL Compatibility}.
multiple-values feature. This file is obsolete and should not be used
in new code. @xref{Old CL Compatibility}.
@node Installation, Naming Conventions, Organization, Overview
@section Installation
......@@ -221,9 +222,10 @@ to install anything.
If you do need to install it, just put the byte-compiled files
@file{cl.elc}, @file{cl-extra.elc}, @file{cl-seq.elc},
@file{cl-macs.elc}, and @file{cl-compat.elc} into a directory on your
@code{load-path}. Also, format the @file{cl.texi} file and put the
resulting Info files into a directory in your @code{Info-directory-list}.
@file{cl-macs.elc}, and (if necessary) @file{cl-compat.elc} into a
directory on your @code{load-path}. Also, format the @file{cl.texi}
file and put the resulting Info files into a directory in your
@code{Info-directory-list}.
@node Naming Conventions, , Installation, Overview
@section Naming Conventions
......@@ -5048,8 +5050,8 @@ Lisp.
@noindent
The @dfn{CL} package includes emulations of some features of the
old @file{cl.el}, in the form of a compatibility package
@code{cl-compat}. To use it, put @code{(require 'cl-compat)} in
your program.
@code{cl-compat}. This file is obsolete and may be removed in future,
so it should not be used in new code.
The old package defined a number of internal routines without
@code{cl-} prefixes or other annotations. Call to these routines
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment