Commit 19151a7f authored by Paul Eggert's avatar Paul Eggert

Emacs crashes with ImageMagick 6.8.2-3 through 6.8.3-9.

* configure.ac (IMAGEMAGICK_MODULE): Reject 6.8.2.
We want to reject 6.8.2-3 through 6.8.3-9, but there seems to be
no way to do this in pkg-config, so make do with a reasonable
approximation.
* etc/PROBLEMS: Mention problem with ImageMagick 6.8.2-3 through 6.8.3-9.

Fixes: debbugs:13867
parent 982efbcd
2013-03-18 Paul Eggert <eggert@cs.ucla.edu>
Emacs crashes with ImageMagick 6.8.2-3 through 6.8.3-9 (Bug#13867).
* configure.ac (IMAGEMAGICK_MODULE): Reject 6.8.2.
We want to reject 6.8.2-3 through 6.8.3-9, but there seems to be
no way to do this in pkg-config, so make do with a reasonable
approximation.
Automate the build of ja-dic.el (Bug#13984).
* .bzrignore: Add leim/ja-dic/.
......
......@@ -1880,7 +1880,8 @@ if test "${HAVE_X11}" = "yes"; then
## 6.2.8 is the earliest version known to work, but earlier versions
## might work - let us know if you find one.
## 6.0.7 does not work. See bug#7955.
IMAGEMAGICK_MODULE="Wand >= 6.2.8"
## 6.8.2 makes Emacs crash; see Bug#13867.
IMAGEMAGICK_MODULE="Wand >= 6.2.8 Wand != 6.8.2"
PKG_CHECK_MODULES(IMAGEMAGICK, $IMAGEMAGICK_MODULE, HAVE_IMAGEMAGICK=yes, :)
AC_SUBST(IMAGEMAGICK_CFLAGS)
AC_SUBST(IMAGEMAGICK_LIBS)
......
2013-03-18 Paul Eggert <eggert@cs.ucla.edu>
Emacs crashes with ImageMagick 6.8.2-3 through 6.8.3-9 (Bug#13867).
* PROBLEMS: Mention problem with ImageMagick 6.8.2-3 through 6.8.3-9.
2013-03-12 Paul Eggert <eggert@cs.ucla.edu>
Add coding tags for iso-2022-7bit files that are not already tagged.
......
......@@ -206,6 +206,10 @@ added a line like this at the beginning of files of Lisp code:
If your tar has this problem, install GNU tar--if you can manage to
untar it :-).
** Emacs crashes when displaying PNG images with simple (tRNS) transparency.
This is due to a bug introduced in ImageMagick 6.8.2-3. The bug
should be fixed in ImageMagick 6.8.3-10. Please see Bug#13867.
** Crashes when displaying GIF images in Emacs built with version
libungif-4.1.0 are resolved by using version libungif-4.1.0b1.
Configure checks for the correct version, but this problem could occur
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment