Commit 1fc8c92b authored by Miles Bader's avatar Miles Bader

Fix admin/quick-install-emacs to work with recent versions of autoconf

Revision: emacs@sv.gnu.org/emacs--devo--0--patch-584
parent db629244
2007-01-01 Miles Bader <miles@gnu.org>
* quick-install-emacs (get_config_var): Deal with weird magic
string inserted by recent versions of autoconf.
2006-11-25 Juanma Barranquero <lekktu@gmail.com>
* admin.el (set-version): Set version number in
......
......@@ -136,7 +136,7 @@ fi
CONFIG_STATUS="$BUILD/config.status"
get_config_var ()
{
if ! sed -n "s/^s\(.\)@$1@\1\(.*\)\1.*$/\2/p" $CONFIG_STATUS | sed q | grep ''
if ! sed -n "s/^s\(.\)@$1@\1\(|#_!!_#|\)*\(.*\)\1.*$/\3/p" $CONFIG_STATUS | sed q | grep ''
then
echo 1>&2 "$me: $1: Configuration variable not found in $CONFIG_STATUS"
exit 4
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment