Commit 357edb4e authored by Artur Malabarba's avatar Artur Malabarba

* lisp/emacs-lisp/package.el: Fix initially wrong compat table

(package--build-compatibility-table): require finder
parent f80027b3
......@@ -1199,6 +1199,8 @@ version higher than the one being used. To check for package
(defun package--build-compatibility-table ()
"Build `package--compatibility-table' with `package--mapc'."
;; Initialize the list of built-ins.
(require 'finder-inf nil t)
;; Build compat table.
(setq package--compatibility-table (make-hash-table :test 'eq))
(package--mapc #'package--add-to-compatibility-table))
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment