Commit 393e94fa authored by Stefan Monnier's avatar Stefan Monnier

* lisp/erc/erc-backend.el: Require `erc' instead of autoloading its macros.

Fixes: debbugs:12669
parent aaf0c300
2012-10-18 Stefan Monnier <monnier@iro.umontreal.ca> 2012-10-18 Stefan Monnier <monnier@iro.umontreal.ca>
* erc-backend.el (erc-with-server-buffer): Autoload as well (bug#12669). * erc-backend.el: Require `erc' instead of autoloading its macros
(bug#12669).
2012-10-15 Stefan Monnier <monnier@iro.umontreal.ca> 2012-10-15 Stefan Monnier <monnier@iro.umontreal.ca>
......
...@@ -99,9 +99,11 @@ ...@@ -99,9 +99,11 @@
(require 'erc-compat) (require 'erc-compat)
(eval-when-compile (require 'cl)) (eval-when-compile (require 'cl))
(autoload 'erc-with-buffer "erc" nil nil 'macro) ;; There's a fairly strong mutual dependency between erc.el and erc-backend.el.
(autoload 'erc-with-server-buffer "erc" nil nil 'macro) ;; Luckily, erc.el does not need erc-backend.el for macroexpansion whereas the
(autoload 'erc-log "erc") ;; reverse is true:
(provide 'erc-backend)
(require 'erc)
;;;; Variables and options ;;;; Variables and options
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment