Commit 493e19b9 authored by Stefan Kangas's avatar Stefan Kangas

Declare some compat aliases obsolete

* lisp/cedet/semantic/tag.el (semantic-token-version)
(semantic-token-incompatible-version):
* lisp/emulation/edt.el (edt-bind-standard-key): Make compat
aliases obsolete.
parent 1ac6330f
......@@ -1321,12 +1321,12 @@ This function is overridable with the symbol `insert-foreign-tag'."
"Insert foreign tags into log-edit mode."
(insert (concat "(" (semantic-format-tag-name foreign-tag) "): ")))
;;; Compatibility
;;; Obsolete
;;
(defconst semantic-token-version
semantic-tag-version)
(defconst semantic-token-incompatible-version
semantic-tag-incompatible-version)
(define-obsolete-variable-alias 'semantic-token-version
'semantic-tag-version "28.1")
(define-obsolete-variable-alias 'semantic-token-incompatible-version
'semantic-tag-incompatible-version "28.1")
(provide 'semantic/tag)
......
......@@ -2161,8 +2161,7 @@ Argument KEY is the name of a key. It can be a standard key or a function key.
Argument BINDING is the Emacs function to be bound to <KEY>."
(define-key edt-user-global-map key binding))
;; For backward compatibility to existing edt-user.el files.
(fset 'edt-bind-standard-key (symbol-function 'edt-bind-key))
(define-obsolete-function-alias 'edt-bind-standard-key #'edt-bind-key "28.1")
(defun edt-bind-gold-key (key gold-binding)
"Binds <GOLD> standard key sequences to custom bindings in the EDT Emulator.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment