Commit 4d766b59 authored by Richard M. Stallman's avatar Richard M. Stallman

(HAVE_JPEG): Turn it off if libjpeg version < 6b.

(HAVE_GIF): Don't use old libungif versions that crash.
parent 857b864a
2002-03-01 Richard M. Stallman <rms@gnu.org>
* configure.in (HAVE_JPEG): Turn it off if libjpeg version < 6b.
(HAVE_GIF): Don't use old libungif versions that crash.
2002-02-26 Richard M. Stallman <rms@gnu.org>
* configure.in <making srcdir absolute>: Verify that PWD is correct,
......
......@@ -1878,6 +1878,16 @@ if test "${HAVE_X11}" = "yes"; then
if test "${HAVE_JPEG}" = "yes"; then
AC_DEFINE(HAVE_JPEG)
AC_EGREP_CPP(
changequote({, })dnl avoid leadingspace on the next line
{version= *(6[2-9]|[7-9][0-9])},
changequote([, ])dnl
[#include <jpeglib.h>
version=JPEG_LIB_VERSION
],
AC_DEFINE(HAVE_JPEG),
[AC_MSG_WARN([libjpeg found, but not version 6b or later])
HAVE_JPEG=no])
fi
fi
......@@ -1915,7 +1925,9 @@ HAVE_GIF=no
if test "${HAVE_X11}" = "yes"; then
if test "${with_gif}" != "no"; then
AC_CHECK_HEADER(gif_lib.h,
AC_CHECK_LIB(ungif, DGifOpen, HAVE_GIF=yes))
# EGifPutExtensionLast only exists from version libungif-4.1.0b1.
# Earlier versions can crash Emacs.
AC_CHECK_LIB(ungif, EGifPutExtensionLast, HAVE_GIF=yes))
fi
if test "${HAVE_GIF}" = "yes"; then
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment