Commit 669ca750 authored by Lars Ingebrigtsen's avatar Lars Ingebrigtsen

Suppress warning about obsolete function custom-show

* lisp/cus-edit.el (custom-variable-value-create): Suppress
warning about obsolete function custom-show.  The widget this
supports has been obsolete since Emacs 24, but we should perhaps
be very conservative about removing widget types, so suppress the
warning instead of removing the widget type.
parent a5cc98c3
Pipeline #2007 failed with stage
in 3 seconds
......@@ -2570,7 +2570,8 @@ try matching its doc string against `custom-guess-doc-alist'."
;; If we don't know the state, see if we need to edit it in lisp form.
(unless state
(setq state (if (custom-show type value) 'unknown 'hidden)))
(with-suppressed-warnings ((obsolete custom-show))
(setq state (if (custom-show type value) 'unknown 'hidden))))
(when (eq state 'unknown)
(unless (widget-apply conv :match value)
(setq form 'mismatch)))
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment