Commit 68b067b3 authored by Paul Eggert's avatar Paul Eggert

Require pkg-config 0.26 or later in autogen.sh only.

* autogen.sh (pkg_config_min): Make this at least 0.26.
* configure.ac (PKG_PROG_PKG_CONFIG): Revert back to 0.9.0.

Fixes: debbugs:17438
parent eab25ea7
......@@ -3,7 +3,7 @@
Require pkg-config 0.26 or later (Bug#17438).
Earlier versions are buggy, as pkg-config --libs can output
nothing, which causes xrandr link failures.
* configure.ac (PKG_PROG_PKG_CONFIG): Bump from 0.9.0 to 0.26.
* autogen.sh (pkg_config_min): Make this at least 0.26.
2014-05-07 Glenn Morris <rgm@gnu.org>
......
......@@ -42,6 +42,11 @@ autoconf_min=`sed -n 's/^ *AC_PREREQ(\([0-9\.]*\)).*/\1/p' configure.ac`
automake_min=`sed -n 's/^ *AM_INIT_AUTOMAKE(\([0-9\.]*\)).*/\1/p' configure.ac`
pkg_config_min=`sed -n 's/^ *PKG_PROG_PKG_CONFIG(\([0-9\.]*\)).*/\1/p' configure.ac`
# Building from the repository needs pkg-config 0.26 or later; see Bug#17438.
case $pkg_config_min in
0.[0-9] | 0.[0-9].* | 0.1[0-9] | 0.1[0-9].* | 0.2[0-5] | 0.2[0-5].* )
pkg_config_min=0.26
esac
## $1 = program, eg "autoconf".
## Echo the version string, eg "2.59".
......
......@@ -1349,7 +1349,7 @@ searched by pkg-config])
pre_PKG_CONFIG_CFLAGS=$CFLAGS
pre_PKG_CONFIG_LIBS=$LIBS
PKG_PROG_PKG_CONFIG(0.26)
PKG_PROG_PKG_CONFIG(0.9.0)
dnl EMACS_CHECK_MODULES(GSTUFF, gtk+-2.0 >= 1.3 glib = 1.3.4)
dnl acts like PKG_CHECK_MODULES(GSTUFF, gtk+-2.0 >= 1.3 glib = 1.3.4,
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment