Commit 72f51d25 authored by Jan Djärv's avatar Jan Djärv

(HAVE_GTK): Print a warning if gtk version is < 2.10.

parent 396dd4da
2008-02-27 Jan Dj$(Q)Z(Brv <jan.h.d@swipnet.se>
* configure.in (HAVE_GTK): Print a warning if gtk version is < 2.10.
2008-02-25 Dan Nicolaescu <dann@ics.uci.edu>
* configure.in: Print an error for systems that we think are
......
......@@ -1666,6 +1666,15 @@ if test x"$pkg_check_gtk" = xyes; then
HAVE_GTK=yes
AC_DEFINE(HAVE_GTK, 1, [Define to 1 if using GTK.])
USE_X_TOOLKIT=none
if $PKG_CONFIG --atleast-version=2.10 gtk+-2.0; then
:
else
AC_MSG_WARN([[Your version of Gtk+ will have problems with
closing open displays. This is no problem if you just use
one display, but if you use more than one and close one of them
Emacs may crash.]])
sleep 3
fi
fi
fi
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment