Commit 7d732d1a authored by Glenn Morris's avatar Glenn Morris
Browse files

Set a minimum automake version

* configure.ac: Require automake 1.11 (fairly arbitrarily).
* autogen.sh (automake_min): Get it from configure.ac.
parent 25a20a3a
2012-08-07 Glenn Morris <rgm@gnu.org>
* configure.ac: Require automake 1.11 (fairly arbitrarily).
* autogen.sh (automake_min): Get it from configure.ac.
2012-08-06 Glenn Morris <rgm@gnu.org>
* configure.ac (BROKEN_GETWD) [unixware]: New define.
......
......@@ -36,8 +36,9 @@ progs="autoconf automake"
## Minimum versions we need:
autoconf_min=`sed -n 's/^ *AC_PREREQ(\([0-9\.]*\)).*/\1/p' configure.ac`
## FIXME how to determine this from the sources?
automake_min=1.11
## This will need improving if more options are ever added to the
## AM_INIT_AUTOMAKE call.
automake_min=`sed -n 's/^ *AM_INIT_AUTOMAKE(\([0-9\.]*\)).*/\1/p' configure.ac`
## $1 = program, eg "autoconf".
......
......@@ -26,7 +26,8 @@ AC_INIT(emacs, 24.1.50)
AC_CONFIG_HEADER(src/config.h:src/config.in)
AC_CONFIG_SRCDIR(src/lisp.h)
AC_CONFIG_AUX_DIR(build-aux)
AM_INIT_AUTOMAKE
dnl Fairly arbitrary, older versions might work too.
AM_INIT_AUTOMAKE(1.11)
dnl Support for --program-prefix, --program-suffix and
dnl --program-transform-name options
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment