Commit 7ec363cf authored by Jan Djärv's avatar Jan Djärv
Browse files

Silence Gtk deprecation warnings by default.

* configure.ac: New enable: --enable-gtk-deprecation-warnings, default off.
(HAVE_GTK3): If above enable is off, add
-DGDK_DISABLE_DEPRECATION_WARNINGS to GTK_CFLAGS.
parent 8b745d92
...@@ -2,6 +2,9 @@ ...@@ -2,6 +2,9 @@
* configure.ac: Check for GtkHandlebox. * configure.ac: Check for GtkHandlebox.
Check for GtkTearoffMenuItem. Check for GtkTearoffMenuItem.
New enable: --enable-gtk-deprecation-warnings, default off.
(HAVE_GTK3): If above enable is off, add
-DGDK_DISABLE_DEPRECATION_WARNINGS to GTK_CFLAGS.
2012-12-30 Andreas Schwab <schwab@linux-m68k.org> 2012-12-30 Andreas Schwab <schwab@linux-m68k.org>
......
...@@ -359,6 +359,11 @@ AC_ARG_ENABLE(autodepend, ...@@ -359,6 +359,11 @@ AC_ARG_ENABLE(autodepend,
found])], found])],
[ac_enable_autodepend="${enableval}"],[ac_enable_autodepend=yes]) [ac_enable_autodepend="${enableval}"],[ac_enable_autodepend=yes])
AC_ARG_ENABLE(gtk-deprecation-warnings,
[AS_HELP_STRING([--enable-gtk-deprecation-warnings],
[Show Gtk+/Gdk deprecation warnings for Gtk+ >= 3.0])],
[ac_enable_gtk_deprecation_warnings="${enableval}"],[])
#### Make srcdir absolute, if it isn't already. It's important to #### Make srcdir absolute, if it isn't already. It's important to
#### avoid running the file name through pwd unnecessarily, since pwd can #### avoid running the file name through pwd unnecessarily, since pwd can
#### give you automounter prefixes, which can go away. We do all this #### give you automounter prefixes, which can go away. We do all this
...@@ -1996,6 +2001,9 @@ if test "${with_gtk3}" = "yes" || test "${with_gtk}" = "yes" || test "$USE_X_TOO ...@@ -1996,6 +2001,9 @@ if test "${with_gtk3}" = "yes" || test "${with_gtk}" = "yes" || test "$USE_X_TOO
GTK_OBJ=emacsgtkfixed.o GTK_OBJ=emacsgtkfixed.o
term_header=gtkutil.h term_header=gtkutil.h
USE_GTK_TOOLKIT="GTK3" USE_GTK_TOOLKIT="GTK3"
if test "x$ac_enable_gtk_deprecation_warnings" = x; then
GTK_CFLAGS="$GTK_CFLAGS -DGDK_DISABLE_DEPRECATION_WARNINGS"
fi
else else
check_gtk2=yes check_gtk2=yes
gtk3_pkg_errors="$GTK_PKG_ERRORS " gtk3_pkg_errors="$GTK_PKG_ERRORS "
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment