Commit 84fc911d authored by Glenn Morris's avatar Glenn Morris

* lisp/subr.el (with-wrapper-hook): Tweak obsolescence message.

* lisp/simple.el: Remove mistaken FIXME comment.

* etc/NEWS: Markup.
parent 3a6e15dd
......@@ -1295,6 +1295,7 @@ This is like the old `eval-after-load', but better behaved.
*** `generic-make-keywords-list'
*** `get-upcase-table' (use `case-table-get-table' instead).
+++
** `with-wrapper-hook' is obsoleted by `add-function'.
The few hooks that used with-wrapper-hook are replaced as follows:
*** `abbrev-expand-function' obsoletes `abbrev-expand-functions'.
......
......@@ -3468,7 +3468,6 @@ extract characters that are special to a buffer, and should not
be copied into other buffers."
(funcall filter-buffer-substring-function beg end delete))
;; FIXME: `with-wrapper-hook' is obsolete
(defun buffer-substring--filter (beg end &optional delete)
(with-wrapper-hook filter-buffer-substring-functions (beg end delete)
(cond
......
......@@ -1461,7 +1461,7 @@ Each hook function definition is used to construct the FUN passed
to the next hook function, if any. The last (or \"outermost\")
FUN is then called once."
(declare (indent 2) (debug (form sexp body))
(obsolete "use a <foo>-function variable modified by add-function."
(obsolete "use a <foo>-function variable modified by `add-function'."
"24.4"))
;; We need those two gensyms because CL's lexical scoping is not available
;; for function arguments :-(
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment