Commit 8854b321 authored by Stefan Kangas's avatar Stefan Kangas
Browse files

Make ad-version variable obsolete

* lisp/emacs-lisp/advice.el (ad-version): Make obsolete in favor
of emacs-version.  It has not been bumped since 1994.
parent 65685920
Pipeline #19877 failed with stages
in 143 minutes and 26 seconds
......@@ -1580,8 +1580,6 @@
:link '(custom-manual "(elisp)Advising Functions")
:group 'lisp)
(defconst ad-version "2.14")
;;;###autoload
(defcustom ad-redefinition-action 'warn
"Defines what to do with redefinitions during Advice de/activation.
......@@ -3250,6 +3248,9 @@ Use only in REAL emergencies."
(message "Oops! Left over advised function %S" function)
(ad-pop-advised-function function)))
(defconst ad-version "2.14")
(make-obsolete-variable 'ad-version 'emacs-version "29.1")
(provide 'advice)
;;; advice.el ends here
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment