Commit 929c0500 authored by Stefan Monnier's avatar Stefan Monnier
Browse files

* lisp/emacs-lisp/package.el (package-built-in-p): Treat a min-version of

0 like nil.
parent 84df8b96
2014-03-28 Stefan Monnier <monnier@iro.umontreal.ca>
* emacs-lisp/package.el (package-built-in-p): Treat a min-version of
0 like nil.
2014-03-27 Dmitry Gutov <dgutov@yandex.ru> 2014-03-27 Dmitry Gutov <dgutov@yandex.ru>
   
* progmodes/ruby-mode.el (ruby-font-lock-keywords): Highlight * progmodes/ruby-mode.el (ruby-font-lock-keywords):
special globals with font-lock-builtin-face. (Bug#17057) Highlight special globals with font-lock-builtin-face. (Bug#17057)
   
* progmodes/ruby-mode.el (ruby-syntax-propertize-function): * progmodes/ruby-mode.el (ruby-syntax-propertize-function):
Don't propertize `?' or `!' as symbol constituent when after Don't propertize `?' or `!' as symbol constituent when after
......
...@@ -536,7 +536,7 @@ specifying the minimum acceptable version." ...@@ -536,7 +536,7 @@ specifying the minimum acceptable version."
(let ((bi (assq package package--builtin-versions))) (let ((bi (assq package package--builtin-versions)))
(cond (cond
(bi (version-list-<= min-version (cdr bi))) (bi (version-list-<= min-version (cdr bi)))
(min-version nil) ((remove 0 min-version) nil)
(t (t
(require 'finder-inf nil t) ; For `package--builtins'. (require 'finder-inf nil t) ; For `package--builtins'.
(assq package package--builtins)))))) (assq package package--builtins))))))
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment