Commit 9dc6e93b authored by Philipp Stephani's avatar Philipp Stephani
Browse files

Explicitly require C11 or C++11 in emacs-module.h

We already implicitly require them by including stdbool.h.  Just make
the error message a bit clearer, and remove an unnecessary version
comparison.
parent 3f89df5c
......@@ -20,11 +20,16 @@ along with GNU Emacs. If not, see <http://www.gnu.org/licenses/>. */
#ifndef EMACS_MODULE_H
#define EMACS_MODULE_H
#if ! (defined __STDC_VERSION__ && __STDC_VERSION__ >= 201112L) \
&& ! (defined __cplusplus && __cplusplus >= 201103L)
# error "This file requires at least C11 or C++11"
#endif
#include <stdint.h>
#include <stddef.h>
#include <stdbool.h>
#if defined __cplusplus && __cplusplus >= 201103L
#if defined __cplusplus
# define EMACS_NOEXCEPT noexcept
#else
# define EMACS_NOEXCEPT
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment