Note that :custom-show is obsolete.

Fixes: debbugs:75
parent a8815b00
2011-07-07 Lars Magne Ingebrigtsen <larsi@gnus.org> 2011-07-07 Lars Magne Ingebrigtsen <larsi@gnus.org>
* cus-edit.el (custom-show): Marked as obsolete.
* net/network-stream.el (network-stream-open-starttls): If gnutls * net/network-stream.el (network-stream-open-starttls): If gnutls
negotiation fails, then possibly try again with a non-encrypted negotiation fails, then possibly try again with a non-encrypted
connection (bug#9017). connection (bug#9017).
......
...@@ -1829,6 +1829,7 @@ item in another window.\n\n")) ...@@ -1829,6 +1829,7 @@ item in another window.\n\n"))
;; We want simple widgets to be displayed by default, but complex ;; We want simple widgets to be displayed by default, but complex
;; widgets to be hidden. ;; widgets to be hidden.
;; This widget type is obsolete as of Emacs 24.1.
(widget-put (get 'item 'widget-type) :custom-show t) (widget-put (get 'item 'widget-type) :custom-show t)
(widget-put (get 'editable-field 'widget-type) (widget-put (get 'editable-field 'widget-type)
:custom-show (lambda (_widget value) :custom-show (lambda (_widget value)
...@@ -2257,6 +2258,7 @@ and `face'." ...@@ -2257,6 +2258,7 @@ and `face'."
(setq widget nil))))) (setq widget nil)))))
(widget-setup)) (widget-setup))
(make-obsolete 'custom-show "this widget type is no longer supported." "24.1")
(defun custom-show (widget value) (defun custom-show (widget value)
"Non-nil if WIDGET should be shown with VALUE by default." "Non-nil if WIDGET should be shown with VALUE by default."
(let ((show (widget-get widget :custom-show))) (let ((show (widget-get widget :custom-show)))
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment