Commit b1631cd7 authored by João Távora's avatar João Távora

Turn Eldoc, Xref and Project into GNU ELPA :core packages

* lisp/jsonrpc.el: Tweak comment near Package-Requires.

* lisp/emacs-lisp/eldoc.el: Add Version and Package-Requires.

* lisp/progmodes/flymake.el: Add comment near Package-Requires.

* lisp/progmodes/project.el: Add Version and Package-Requires.

* lisp/progmodes/xref.el: Add Version and Package-Requires.
parent dd0b910f
Pipeline #5540 passed with stage
in 65 minutes and 50 seconds
......@@ -5,6 +5,11 @@
;; Author: Noah Friedman <friedman@splode.com>
;; Keywords: extensions
;; Created: 1995-10-06
;; Version: 1.0.0
;; Package-Requires: ((emacs "26.3"))
;; This is a GNU ELPA :core package. Don't use functionality that is
;; not compatible with the version of Emacs recorded above.
;; This file is part of GNU Emacs.
......
......@@ -4,11 +4,11 @@
;; Author: João Távora <joaotavora@gmail.com>
;; Keywords: processes, languages, extensions
;; Package-Requires: ((emacs "25.2"))
;; Version: 1.0.11
;; Package-Requires: ((emacs "25.2"))
;; This is an Elpa :core package. Don't use functionality that is not
;; compatible with Emacs 25.2.
;; This is a GNU ELPA :core package. Don't use functionality that is
;; not compatible with the version of Emacs recorded above.
;; This program is free software; you can redistribute it and/or modify
;; it under the terms of the GNU General Public License as published by
......
......@@ -5,8 +5,11 @@
;; Author: Pavel Kobyakov <pk_at_work@yahoo.com>
;; Maintainer: João Távora <joaotavora@gmail.com>
;; Version: 1.0.8
;; Package-Requires: ((emacs "26.1"))
;; Keywords: c languages tools
;; Package-Requires: ((emacs "26.1"))
;; This is a GNU ELPA :core package. Don't use functionality that is
;; not compatible with the version of Emacs recorded above.
;; This file is part of GNU Emacs.
......
;;; project.el --- Operations on the current project -*- lexical-binding: t; -*-
;; Copyright (C) 2015-2020 Free Software Foundation, Inc.
;; Version: 1.0.0
;; Package-Requires: ((emacs "27.1"))
;; This is a GNU ELPA :core package. Don't use functionality that is
;; not compatible with the version of Emacs recorded above.
;; This file is part of GNU Emacs.
......
;; xref.el --- Cross-referencing commands -*-lexical-binding:t-*-
;; Copyright (C) 2014-2020 Free Software Foundation, Inc.
;; Version: 1.0.0
;; Package-Requires: ((emacs "27.1") (project "1.0.0"))
;; This is a GNU ELPA :core package. Don't use functionality that is
;; not compatible with the version of Emacs recorded above.
;; This file is part of GNU Emacs.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment