Commit b55d4a5d authored by Glenn Morris's avatar Glenn Morris

Petr Salinger <Petr.Salinger at seznam.cz>:

Add support for gnu-kfreebsd.
parent 9485484a
2007-11-28 Petr Salinger <Petr.Salinger@seznam.cz> (tiny change)
* configure.in: Add support for gnu-kfreebsd.
2007-09-16 Peter O'Gorman <bug-gnu-emacs@mlists.thewrittenword.com> (tiny change)
* configure.in: Don't use -lpthread on HP-UX.
......
......@@ -249,6 +249,19 @@ case "${canonical}" in
esac
;;
## FreeBSD kernel + glibc based userland
*-*-kfreebsd*gnu* )
opsys=gnu-kfreebsd
case "${canonical}" in
alpha*-*-kfreebsd*) machine=alpha ;;
ia64-*-kfreebsd*) machine=ia64 ;;
sparc64-*-kfreebsd*) machine=sparc ;;
powerpc-*-kfreebsd*) machine=macppc ;;
i[3456]86-*-kfreebsd*) machine=intel386 ;;
amd64-*-kfreebsd*|x86_64-*-kfreebsd*) machine=amdx86-64 ;;
esac
;;
## NetBSD ports
*-*-netbsd* )
opsys=netbsd
......
......@@ -40,6 +40,8 @@ below. Emacs tries to warn you about these through `bad-packages-alist'.
** Emacs is now licensed under the GNU GPL version 3 (or later).
** Support for GNU/kFreeBSD (GNU userland and FreeBSD kernel) was added.
* Changes in Emacs 22.2
** In Image mode, whenever the displayed image is wider and/or higher
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment