Commit c17e9c60 authored by Romain Francoise's avatar Romain Francoise

Adapt make-dist to new version location.

* make-dist: Look for version in src/emacs.c.
Use lisp/subr.el rather than lisp/version.el for location check.
parent 6ec0221e
2010-05-24 Romain Francoise <romain@orebokech.com>
* make-dist: Look for version in src/emacs.c.
Use lisp/subr.el rather than lisp/version.el for location check.
2010-05-21 Glenn Morris <rgm@gnu.org>
* configure.in (MKDEPDIR): Parallel build tweak.
......
......@@ -121,8 +121,8 @@ while [ $# -gt 0 ]; do
done
### Make sure we're running in the right place.
if [ ! -d src -o ! -f src/lisp.h -o ! -d lisp -o ! -f lisp/version.el ]; then
echo "${progname}: Can't find \`src/lisp.h' and \`lisp/version.el'." >&2
if [ ! -d src -o ! -f src/lisp.h -o ! -d lisp -o ! -f lisp/subr.el ]; then
echo "${progname}: Can't find \`src/lisp.h' and \`lisp/subr.el'." >&2
echo "${progname} must be run in the top directory of the Emacs" >&2
echo "distribution tree. cd to that directory and try again." >&2
exit 1
......@@ -150,12 +150,12 @@ then
fi
### Find out which version of Emacs this is.
shortversion=`grep 'defconst[ ]*emacs-version' lisp/version.el \
shortversion=`grep 'char emacs_version' src/emacs.c \
| sed -e 's/^.*"\([0-9][0-9]*\.[0-9][0-9]*\).*$/\1/'`
version=`grep 'defconst[ ]*emacs-version' lisp/version.el \
version=`grep 'char emacs_version' src/emacs.c \
| sed -e 's/^[^"]*"\([^"]*\)".*$/\1/'`
if [ ! "${version}" ]; then
echo "${progname}: can't find current Emacs version in \`./lisp/version.el'" >&2
echo "${progname}: can't find current Emacs version in \`./src/emacs.c'" >&2
exit 1
fi
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment