Commit cd890796 authored by Jan Djärv's avatar Jan Djärv

Fixed --with-gtk

parent 22174d10
2003-01-20 Jan D. <jan.h.d@swipnet.se>
* configure.in: Fix --with-gtk.
2003-01-19 Jan D. <jan.h.d@swipnet.se>
* configure.in: Add --with-gtk, --with-x-toolkit=gtk
......
......@@ -1890,7 +1890,22 @@ case "${canonical}" in
machine=pmax opsys=mach-bsd4-3
;;
## Motorola Delta m88k
## Motorola Delta machines
m68k-motorola-sysv* | m68000-motorola-sysv* )
machine=delta opsys=usg5-3
if test -z "`type gnucc | grep 'not found'`"
then
if test -s /etc/167config
then CC="gnucc -m68040"
else CC="gnucc -m68881"
fi
else
if test -z "`type gcc | grep 'not found'`"
then CC=gcc
else CC=cc
fi
fi
;;
m88k-motorola-sysv4* )
# jbotte@bnr.ca says that UNIX_System_V <hostName> 4.0 R40V4.3 m88k mc88110
# needs POSIX_SIGNALS and therefore needs usg5-4-2.
......@@ -8080,7 +8095,7 @@ fi
HAVE_GTK=no
if test "${with_gtk}" = "yes" || test "$USE_X_TOOLKIT" = "gtk"; then
if test "$USE_X_TOOLKIT" != "none"; then
if test "$USE_X_TOOLKIT" != "none" && test "$USE_X_TOOLKIT" != "maybe"; then
{ { echo "$as_me:$LINENO: error: Conflicting options, --with-gtk is incompatible with --with-x-toolkit=${with_x_toolkit}" >&5
echo "$as_me: error: Conflicting options, --with-gtk is incompatible with --with-x-toolkit=${with_x_toolkit}" >&2;}
{ (exit 1); exit 1; }; };
......
......@@ -1849,7 +1849,7 @@ AC_DEFUN(PKG_CHECK_MODULES, [
HAVE_GTK=no
if test "${with_gtk}" = "yes" || test "$USE_X_TOOLKIT" = "gtk"; then
if test "$USE_X_TOOLKIT" != "none"; then
if test "$USE_X_TOOLKIT" != "none" && test "$USE_X_TOOLKIT" != "maybe"; then
AC_MSG_ERROR([Conflicting options, --with-gtk is incompatible with --with-x-toolkit=${with_x_toolkit}]);
fi
GLIB_REQUIRED=2.0.1
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment