Commit d6261cc1 authored by Glenn Morris's avatar Glenn Morris
Browse files

(rmail-obsolete): Delete custom group.

(rmail-pop-password, rmail-pop-password-required): Make into aliases.
(rmail-remote-password, rmail-remote-password-required):
Remove unneeded :set-after and :set properties.
parent 9e846523
2009-08-21 Glenn Morris <rgm@gnu.org>
* mail/rmail.el (rmail-obsolete): Delete custom group.
(rmail-pop-password, rmail-pop-password-required): Make into aliases.
(rmail-remote-password, rmail-remote-password-required):
Remove unneeded :set-after and :set properties.
2009-08-21 Michael Albinus <michael.albinus@gmx.de>
* net/dbus.el (top): Initialize only when `dbusbind' is loaded.
......
......@@ -139,57 +139,28 @@ its character representation and its display representation.")
:prefix "rmail-edit-"
:group 'rmail)
(defgroup rmail-obsolete nil
"Rmail obsolete customization variables."
:group 'rmail)
(defcustom rmail-movemail-program nil
"If non-nil, the file name of the `movemail' program."
:group 'rmail-retrieve
:type '(choice (const nil) string))
(defcustom rmail-pop-password nil
"Password to use when reading mail from POP server.
Please use `rmail-remote-password' instead."
:type '(choice (string :tag "Password")
(const :tag "Not Required" nil))
:group 'rmail-obsolete)
(defcustom rmail-pop-password-required nil
"Non-nil if a password is required when reading mail from a POP server.
Please use rmail-remote-password-required instead."
:type 'boolean
:group 'rmail-obsolete)
(define-obsolete-variable-alias 'rmail-pop-password
'rmail-remote-password "22.1")
(defcustom rmail-remote-password nil
"Password to use when reading mail from a remote server.
This setting is ignored for mailboxes whose URL already contains a password."
:type '(choice (string :tag "Password")
(const :tag "Not Required" nil))
:set-after '(rmail-pop-password)
:set #'(lambda (symbol value)
(set-default symbol
(if (and (not value)
(boundp 'rmail-pop-password)
rmail-pop-password)
rmail-pop-password
value))
(setq rmail-pop-password nil))
:group 'rmail-retrieve
:version "22.1")
(define-obsolete-variable-alias 'rmail-pop-password-required
'rmail-remote-password-required "22.1")
(defcustom rmail-remote-password-required nil
"Non-nil if a password is required when reading mail from a remote server."
:type 'boolean
:set-after '(rmail-pop-password-required)
:set #'(lambda (symbol value)
(set-default symbol
(if (and (not value)
(boundp 'rmail-pop-password-required)
rmail-pop-password-required)
rmail-pop-password-required
value))
(setq rmail-pop-password-required nil))
:group 'rmail-retrieve
:version "22.1")
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment