Commit e4dd707c authored by Dave Love's avatar Dave Love
Browse files

Notes on fonts, Debian packages.

parent 463f55ee
GNU Emacs Installation Guide GNU Emacs Installation Guide
Copyright (c) 1992, 1994, 1996, 1997, 2000, 2001 Free software Foundation, Inc. Copyright (c) 1992, 94, 96, 97, 2000, 01, 02 Free software Foundation, Inc.
See the end of the file for copying permissions. See the end of the file for copying permissions.
...@@ -93,13 +93,13 @@ ADDITIONAL DISTRIBUTION FILES ...@@ -93,13 +93,13 @@ ADDITIONAL DISTRIBUTION FILES
* intlfonts-VERSION.tar.gz * intlfonts-VERSION.tar.gz
The intlfonts distribution contains X11 fonts that Emacs needs in The intlfonts distribution contains X11 fonts in various encodings
order to display international characters. If you see a non-ASCII that Emacs can use to display international characters. If you see a
character appear as a hollow box, that means you don't have a font for non-ASCII character appear as a hollow box, that means you don't have
it. You might find a font in the intlfonts distribution. If you do a font for it. You might find one in the intlfonts distribution. If
have a font for a non-ASCII character, but some characters don't look you do have a font for a non-ASCII character, but some characters
right, or appear improperly aligned, a font from the intlfonts don't look right, or appear improperly aligned, a font from the
distribution might look better. intlfonts distribution might look better.
The fonts in the intlfonts distribution are also used by the ps-print The fonts in the intlfonts distribution are also used by the ps-print
package for printing international characters. The file package for printing international characters. The file
...@@ -156,17 +156,23 @@ At first, Emacs does not include fonts and does not install them. You ...@@ -156,17 +156,23 @@ At first, Emacs does not include fonts and does not install them. You
must do this yourself. must do this yourself.
To take proper advantage of Emacs 21's mule-unicode charsets, you need To take proper advantage of Emacs 21's mule-unicode charsets, you need
a Unicode font. For information on Unicode fonts for X, see a suitable font. For `Unicode' (ISO 10646) fonts for X, see
<URL:http://czyborra.com/unifont/>, <URL:http://dvdeug.dhis.org/unifont.html> (packaged in Debian),
<URL:http://openlab.ring.gr.jp/efont/> and <URL:http://openlab.ring.gr.jp/efont/> (packaged in Debian). (In
recent Debian versions, there is an extensive `misc-fixed' iso10646-1
in the default X installation.) Perhaps also see
<URL:http://www.cl.cam.ac.uk/%7Emgk25/ucs-fonts.html>. <URL:http://www.cl.cam.ac.uk/%7Emgk25/ucs-fonts.html>.
<URL:http://czyborra.com/charsets/> has basic fonts for Emacs's <URL:http://czyborra.com/charsets/> has basic fonts for Emacs's
ISO-8859 charsets. ISO-8859 charsets.
XFree86 release 4 (from <URL:ftp://ftp.xfree86.org/> and mirrors) XFree86 release 4 (from <URL:ftp://ftp.xfree86.org/> and mirrors)
contains font support for most, if not all, of the charsets that Emacs contains font support for most, if not all, of the charsets that Emacs
supports. The font files should be usable separately with older X currently supports, including iso10646-1 encoded fonts for use with
releases. the mule-unicode charsets. The font files should also be usable with
older X releases. Note that XFree 4 contains many iso10646-1 fonts
with minimal character repertoires, which can cause problems -- see
etc/PROBLEMS.
BDF fonts etl-unicode.tar.gz used by ps-print and ps-mule to print BDF fonts etl-unicode.tar.gz used by ps-print and ps-mule to print
Unicode characters are available from <URL:ftp://ftp.x.org/contrib/fonts/> Unicode characters are available from <URL:ftp://ftp.x.org/contrib/fonts/>
...@@ -179,8 +185,10 @@ default; they just include the files that you need to run Emacs, but ...@@ -179,8 +185,10 @@ default; they just include the files that you need to run Emacs, but
not those you need to compile it. For example, to compile Emacs with not those you need to compile it. For example, to compile Emacs with
X11 support, you may need to install the special `X11 development' X11 support, you may need to install the special `X11 development'
package. For example, in April 2003, the package names to install package. For example, in April 2003, the package names to install
were `xlibs-dev' and `libxaw7-dev' on Debian and `XFree86-devel' and were `XFree86-devel' and `Xaw3d-devel' on RedHat. On Debian, the
`Xaw3d-devel' on RedHat. packages necessary to build the installed version should be
sufficient; they can be installed using `apt-get build-dep emacs21' in
Debian 3 and above.
DETAILED BUILDING AND INSTALLATION: DETAILED BUILDING AND INSTALLATION:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment