Commit e687aa33 authored by Vincent Belaïche's avatar Vincent Belaïche
Browse files

Add a question into configure.bat whether the user want to continue at

his/her own risks.
parent 67aeda8d
2013-08-25 Vincent Belaïche <vincentb1@users.sourceforge.net>
* configure.bat: Rather than disabling, make configure.bat produce
some warning that building with configure.bat is deprecated and
ask for confirmation to continue.
2013-08-25 Glenn Morris <rgm@gnu.org>
* INSTALL: Refer to INSTALL.MSYS.
......
......@@ -58,10 +58,20 @@ rem look for "cygpath" near line 85 of gmake.defs.
rem [7] not recommended; please report if you try this combination.
rem [8] tested only on Windows XP.
rem
echo This method of building Emacs is no longer supported.
echo Instead, follow the instructions from INSTALL.MSYS.
goto end
echo ****************************************************************
echo *** THIS METHOD OF BUILDING EMACS IS NO LONGER SUPPORTED. **
echo *** INSTEAD, FOLLOW THE INSTRUCTIONS FROM INSTALL.MSYS. **
echo ****************************************************************
:confirm_continue
set /p answer=Continue running this script at your own risks ? (Y/N)
if x%answer% == xy (goto confirm_continue_y)
if x%answer% == xY (goto confirm_continue_y)
if x%answer% == xn (goto end)
if x%answer% == xN (goto end)
echo Please answer by Y or N
goto confirm_continue
:confirm_continue_y
if exist config.log del config.log
rem ----------------------------------------------------------------------
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment