Commit e792450d authored by Michael Albinus's avatar Michael Albinus

Sync with Tramp 2.2.11.

* net/tramp-compat.el (top): Require cl-macs for Emacs 22.
Make an alias for `default-toplevel-value' if it doesn't exist.

* net/tramp-smb.el (tramp-smb-handle-copy-directory):
Use `tramp-compat-delete-directory'.

* net/trampver.el: Update release number.
parent 2d17e122
2014-12-29 Michael Albinus <michael.albinus@gmx.de>
Sync with Tramp 2.2.11.
* net/tramp-compat.el (top): Require cl-macs for Emacs 22.
Make an alias for `default-toplevel-value' if it doesn't exist.
* net/tramp-smb.el (tramp-smb-handle-copy-directory):
Use `tramp-compat-delete-directory'.
* net/trampver.el: Update release number.
2014-12-29 Filipp Gunbin <fgunbin@fastmail.fm>
* autorevert.el (auto-revert-handler): Fix auto-revert-tail-mode
......
......@@ -35,6 +35,11 @@
(eval-and-compile
;; GNU Emacs 22.
(unless (fboundp 'ignore-errors)
(load "cl" 'noerror)
(load "cl-macs" 'noerror))
;; Some packages must be required for XEmacs, because we compile
;; with -no-autoloads.
(when (featurep 'xemacs)
......@@ -586,6 +591,10 @@ and replace a sub-expression, e.g.
(setq matches (cons (substring string start l) matches)) ; leftover
(apply #'concat (nreverse matches))))))
;; `default-toplevel-value' has been declared in Emacs 24.
(unless (fboundp 'default-toplevel-value)
(defalias 'default-toplevel-value 'symbol-value))
(add-hook 'tramp-unload-hook
(lambda ()
(unload-feature 'tramp-loaddefs 'force)
......
......@@ -513,7 +513,7 @@ pass to the OPERATION."
;; Reset the transfer process properties.
(tramp-set-connection-property v "process-name" nil)
(tramp-set-connection-property v "process-buffer" nil)
(when t1 (delete-directory tmpdir 'recurse))))
(when t1 (tramp-compat-delete-directory tmpdir 'recurse))))
;; Handle KEEP-DATE argument.
(when keep-date
......
......@@ -31,7 +31,7 @@
;; should be changed only there.
;;;###tramp-autoload
(defconst tramp-version "2.2.11-pre"
(defconst tramp-version "2.2.11-24.5"
"This version of Tramp.")
;;;###tramp-autoload
......@@ -44,7 +44,7 @@
(= emacs-major-version 21)
(>= emacs-minor-version 4)))
"ok"
(format "Tramp 2.2.11-pre is not fit for %s"
(format "Tramp 2.2.11-24.5 is not fit for %s"
(when (string-match "^.*$" (emacs-version))
(match-string 0 (emacs-version)))))))
(unless (string-match "\\`ok\\'" x) (error "%s" x)))
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment