Commit fa953b58 authored by Glenn Morris's avatar Glenn Morris

Fix an epg test for recent GnuPG versions (bug#33439)

* test/lisp/epg-tests.el (epg-decrypt-1):
Tell recent GnuPG (e.g. 2.2.11) not to worry about missing MDC.
parent 30156364
Pipeline #287 failed with stage
in 3 seconds
......@@ -87,6 +87,8 @@
(ert-deftest epg-decrypt-1 ()
(skip-unless (epg-tests-find-usable-gpg-configuration 'require-passphrase))
(with-epg-tests (:require-passphrase t)
(with-temp-file (expand-file-name "gpg.conf" epg-tests-home-directory)
(insert "ignore-mdc-error"))
(should (equal "test"
(epg-decrypt-string epg-tests-context "\
-----BEGIN PGP MESSAGE-----
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment